Linux Mint 14 Cinnamon on Dell XPS

After two years of using Linux Mint 12 Cinnamon 64-bit on my Dell XPS desktop I finally decided to wipe LM 12 and install a newer version. With the release of Linux Mint 15 I was hearing widespread good news about this version so I decided I was finally going to upgrade. It is worth mentioning, though, that in the two years I was running LM 12 on my desktop that I never had any issues; it was all very stable except for the couple of times I made the mistake of attempting an Nvidia driver update. My plan for the upgrade was to install Linux Mint 15 on my Dell Vostro laptop first to see how things would go. Well, if you read my previous post you know that I had a real headache. With that catastrophe behind me I still decided I would attempt an install of LM 15 on my XPS desktop just so that I could get to Cinnamon 1.8. I booted up into the LM 15 Live USB thumb drive on my XPS and immediately ran into some performance issues, my mouse completely froze and I had no response from the keyboard. Essentially, my computer froze. I didn’t give up just yet. I so happen to have a spare Dell XPS desktop lying around; my nephew had also used the same XPS machine but had recently shelved it since we had built him a new, powerful gaming machine. I powered it up with the same LM 15 Live USB thumb drive and experienced the exact same issue. Still I didn’t give up. Just for the heck of it I decided to burn a DVD of LM 15. Same thing happened. It was then that I determined that my system just couldn’t handle Linux Mint 15 Cinnamon for whatever reason. It was then that I decided that it looked as if LM 14 would have to be installed on my desktop also.

I proceeded to install Linux Mint 14 Cinnamon 64-bit without any hassle and even found a means to upgrade Cinnamon to 1.8 thereafter by simply selecting the check for Backported packages from the Software Sources.

SoftSource

I re-installed most of my usual applications including, of course, Conky. I have found that Conky, for me, has become a necessity. With a theme I had used in the past called Next Gen I decided to customize the Next Gen theme some more based on a Tron wallpaper I had found. Because there were so many lines in the wallpaper I couldn’t see the metrics within Conky so I decided to create some transparent rectangles to insert into the Conky theme for the metrics to lay on top of for visibility. And this is what I came up with:

ConkyDesktop

So far these past few days have been great with the new install of Linux Mint 14 Cinnamon 64-bit. It’s been running smooth and I am very happy. Of course, I will be much happier when I can afford to build a more powerful machine like we did for my nephew.

Linux Mint 15 Cinnamon on Dell Vostro V130

Well, Linux Mint 15 was released a couple of weeks ago and if you have been following my blog closely I usually complete the newest upgrade of Mint on my Dell Vostro V130 laptop that is a dual-boot with Windows 7. With the release of Mint 15 came some really nice features, one of which was an update to Cinnamon; I’m a big fan of the Cinnamon desktop environment. When Mint 15 was released I was really looking forward to installing it on my Vostro and most of all I was finally planning on upgrading my Dell XPS desktop from Mint 12 to Mint 15 since I hadn’t upgraded in the two years since Mint 12 was released. I completed the install on my Vostro with no problems and even proceeded with customizing Conky, which is usually the first thing I do as soon as I install Linux Mint. The install was smooth and everything was working just fine for awhile until I received a GRUB boot error attempting to boot into Linux Mint.
Boot Error 02
I immediately powered off and powered it back on and received a different boot error referencing GRUB.
Boot Error 01
With this error at least I was given the option to press a key, in which I did and it booted into the operating system. For troubleshooting, I attempted a restart to see if I received the same boot error when booting into Windows 7, which I did. Throughout my booting troubleshooting I would intermittently receive those same random boot errors and sometimes I would boot right into whatever operating system I chose without a boot error. It was strange. Before this whole boot issue, though, I had heard the occasional clicking noise coming from my 320GB hard drive, I was under the assumption that my hard drive was going bad so I figured this was the reason I was receiving these boot errors. I ran some hard drive diagnostics to determine if the drive was bad but every test I ran from different providers found no issue with the drive. My next step was to completely format the drive and just install Linux Mint instead of both operating systems side by side. After I was still receiving the intermittent boot errors I then wiped the drive completely and installed Windows 7 by itself and everything seem to work just fine for a short while but then I started receiving the GRUB boot errors again. This led me to believe that GRUB was still used in the Master Boot Record so I used Windows 7 Repair to delete the MBR and reinstalled Windows 7 from an image from when I cloned it with Clonezilla a few months back but still received boot errors. With all of this, even though the hard drive diagnostics ran clean, I decided that I must have a bad drive so I bought a new 500GB hard drive from the local electronics store and proceeded with a new install of Linux Mint 14 that I had from an image from when I had cloned Linux Mint 14 on the Vostro using Clonezilla. Surprisingly, I was still having boot errors with this new drive. From there I tried many other troubleshooting scenarios, so many to list that it would make this post that much longer. One of the steps was to attempt to use the Ubuntu utility called Boot-Repair. After many attempts to fix my errors with the utility and communication and assistance from the utility developer I never could get rid of the intermittent boot errors.
Let’s wrap this up by stating that I decided to try a completely different hard drive. I had an external USB 160GB SATA hard drive that I had been using as travel storage. I removed the drive from the enclosure and inserted it into the laptop and put the 500GB into the external enclosure. I then proceeded to install a fresh copy of Linux Mint 14 with Cinnamon and all is well. It’s really quite strange. I’ve been using the laptop without any boot errors at all for the past four days. I’ve been working in the IT industry as a Systems Administrator for the past 12 years and working with computers for the past 20 years and I can honestly say that this has been the most perplexing hardware/operating system issue I have ever encountered. I really haven’t a clue as to the root cause of this boot issue. What makes it even more perplexing is that I put that original 320GB hard drive into a spare desktop that was lying around the house and it is running Linux Mint 15 Cinnamon with no boot errors whatsoever. The only possible factor I could point my finger that may have caused the issue from the beginning was maybe, just maybe, Clonezilla and the images I was working with.
I haven’t decided yet if I will be formatting the Vostro and installing Linux Mint 15 Cinnamon. I’m at that point where it’s now a perfectly good working machine with no issues and I don’t want to screw it up. I did, however, upgrade Cinnamon to 1.8 with the help from someone in the Linux Mint IRC by simply going into Software Sources and selecting ‘Backport packages’. I’m still in the process of customizing Conky on it. I’m starting with something from scratch so I may be posting a screenshot of my completed Conky project here later.